be8c20e0

ПоГруппировкамСИерархией


;  

Выборка = Запрос.Выполнить().Выбрать(СпособВыборки);  

ВыдатьРекурсивно (Выборка);  

КонецПроцедуры

 

Процедура ВыдатьРекурсивно(Выборка)

Пока Выборка.Следующий() Цикл

 

//выведем в окно сообщений поля из результата   

Товар = Выборка.Наименование;  

Количество = Выборка.Количество;  

Сообщить("Товар: " + СокрЛП(Товар) +  

"Количество: " + СокрЛП(Количество));  

 

//продолжим выборку подчиненных записей  

СпособВыборки = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;  

ВыдатьРекурсивно(Выборка.Выбрать(СпособВыборки));  

КонецЦикла;  

КонецПроцедуры




Начало  Назад  Вперед