be8c20e0

ПоГруппировкамСИерархией


;  

Выборка = Запрос.Выполнить().Выбрать(СпособВыборки);  

ВыдатьРекурсивно (Выборка);  

КонецПроцедуры

 

Процедура ВыдатьРекурсивно(Выборка)

Пока Выборка.Следующий() Цикл

 

//выведем в окно сообщений поля из результата   

Товар = Выборка.Наименование;  

Количество = Выборка.Количество;  

Сообщить("Товар: " + СокрЛП(Товар) +  

"Количество: " + СокрЛП(Количество));  

 

//продолжим выборку подчиненных записей  

СпособВыборки = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;  

ВыдатьРекурсивно(Выборка.Выбрать(СпособВыборки));  

КонецЦикла;  

КонецПроцедуры



Начало  Назад  Вперед





Forekc.ru
Рефераты, дипломы, курсовые, выпускные и квалификационные работы, диссертации, учебники, учебные пособия, лекции, методические пособия и рекомендации, программы и курсы обучения, публикации из профильных изданий